Verified Commit 5480fb34 authored by Aral Balkan's avatar Aral Balkan
Browse files

Upgrade to Nodecert 3.0.0 with Nexe support; fixes #7

parent 10a677e1
......@@ -32,7 +32,7 @@ async function build () {
input: 'bin/web-server.js',
output: `${linuxVersionPath}/web-server`,
target: 'linux-x64-10.15.3',
resources: ['package.json', 'bin/daemon.js']
resources: ['package.json', 'node_modules/@ind.ie/nodecert/mkcert-bin/mkcert-v1.3.0-linux-amd64', 'node_modules/@ind.ie/nodecert/mkcert-bin/mkcert-v1.3.0-linux-arm']
})
console.log(' • Building macOS version…')
......@@ -41,7 +41,7 @@ async function build () {
input: 'bin/web-server.js',
output: `${macOSVersionPath}/web-server`,
target: 'mac-x64-10.15.3',
resources: ['package.json', 'bin/daemon.js']
resources: ['package.json', 'node_modules/@ind.ie/nodecert/mkcert-bin/mkcert-v1.3.0-darwin-amd64']
})
//
......
......@@ -47,9 +47,9 @@
}
},
"@ind.ie/nodecert": {
"version": "2.1.0",
"resolved": "https://registry.npmjs.org/@ind.ie/nodecert/-/nodecert-2.1.0.tgz",
"integrity": "sha512-nB6HLITL7+9VAE6eA9wb1xFbG6oPw6fcxW7HnVoi4VPWK8Kba3JORgPKP69Kn+1n0v2hmNLmBWpJ0VV0GdAu6Q==",
"version": "3.0.0",
"resolved": "https://registry.npmjs.org/@ind.ie/nodecert/-/nodecert-3.0.0.tgz",
"integrity": "sha512-H1lwUY2uUO/+Vn6oxGtEZUR3JBaTHQHRi0/6YCb37JpEG8hrz+aAl2ObSXi66evkGoU7VxUz2uts2O6J7BG2jA==",
"requires": {
"syswide-cas": "^5.3.0"
}
......
......@@ -21,7 +21,7 @@
"license": "AGPL-3.0-or-later",
"dependencies": {
"@ind.ie/acme-tls": "^2.1.2",
"@ind.ie/nodecert": "^2.1.0",
"@ind.ie/nodecert": "^3.0.0",
"ansi-escape-sequences": "^4.1.0",
"copy-concurrently": "^1.0.5",
"express": "^4.16.4",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment