Commit c0a605da authored by Stefan van den Oord's avatar Stefan van den Oord

Fixed dependencies and minimum iOS version in pod spec

parent 1a77b437
......@@ -5,7 +5,7 @@ use_frameworks!
target 'Pulse' do
pod 'SwiftBytes', '~> 0.2'
pod 'CocoaAsyncSocket', '~> 7.4', :inhibit_warnings => true
pod 'CocoaAsyncSocket', '~> 7.4.0', :inhibit_warnings => true
pod 'lz4', '~> 128', :inhibit_warnings => true
pod 'Base32', '~> 1.0.2'
pod 'IGDigest', '~> 1.1.0'
......
......@@ -20,7 +20,7 @@ PODS:
DEPENDENCIES:
- Base32 (~> 1.0.2)
- CocoaAsyncSocket (~> 7.4)
- CocoaAsyncSocket (~> 7.4.0)
- IGDigest (~> 1.1.0)
- lz4 (~> 128)
- NetUtils (~> 2.0)
......@@ -41,6 +41,6 @@ SPEC CHECKSUMS:
SelfSignedCert: eeb068ecdbccc68bfd5e8955f7b3df55394d656a
SwiftBytes: 262e08479bc103bbb4eccd296e8b8ffb2102f7c3
PODFILE CHECKSUM: 0ed3b8685b466f0ff8d30df5b3549ecb1183e5d2
PODFILE CHECKSUM: 82c01ec56e63e51c938eda46db78d58687397b43
COCOAPODS: 1.0.1
{
"name": "SelfSignedCert",
"version": "0.0.1",
"summary": "A Swift library to create self-signed certificates on iOS",
"description": "On iOS, you cannot simply create self-signed certificates.\nYou could try and pull out OpenSSL, but that will turn into\na nightmare very quickly. This library provides functionality\nto create self-signed certificates in Swift. DISCLAIMER: I\nam no security expert. This library has not been audited by\none. I just ported a part of another library, copying many\nof the unit tests in there, but I don't know if they were all\ncorrect... Use at your own risk! By the way: if you are a\nsecurity expert and want to audit this library, that would\nearn you LOTS and LOTS of gratitude! Please contact me.",
"homepage": "https://bitbucket.org/svdoord/selfsignedcert",
"license": {
"type": "MIT",
"file": "LICENSE.txt"
},
"authors": {
"Stefan van den Oord": "soord@mac.com"
},
"platforms": {
"ios": "9.0"
},
"source": {
"git": "https://bitbucket.org/svdoord/selfsignedcert",
"tag": "0.0.1"
},
"source_files": "SelfSignedCert/**/*.swift",
"dependencies": {
"IDZSwiftCommonCrypto": [
"~> 0.7"
],
"SwiftBytes": [
"~> 0.2"
]
}
}
......@@ -20,7 +20,7 @@ PODS:
DEPENDENCIES:
- Base32 (~> 1.0.2)
- CocoaAsyncSocket (~> 7.4)
- CocoaAsyncSocket (~> 7.4.0)
- IGDigest (~> 1.1.0)
- lz4 (~> 128)
- NetUtils (~> 2.0)
......@@ -41,6 +41,6 @@ SPEC CHECKSUMS:
SelfSignedCert: eeb068ecdbccc68bfd5e8955f7b3df55394d656a
SwiftBytes: 262e08479bc103bbb4eccd296e8b8ffb2102f7c3
PODFILE CHECKSUM: 0ed3b8685b466f0ff8d30df5b3549ecb1183e5d2
PODFILE CHECKSUM: 82c01ec56e63e51c938eda46db78d58687397b43
COCOAPODS: 1.0.1
......@@ -9,7 +9,7 @@ Pod::Spec.new do |s|
s.homepage = "https://source.ind.ie/project/pulse-swift"
#s.license = "MIT (example)"
s.authors = "dapperstout", "Stefan van den Oord"
s.platform = :ios, "8.0"
s.platform = :ios, "9.0"
s.source = { :git => "https://source.ind.ie/project/pulse-swift.git", :tag => "0.0.1" }
......@@ -19,10 +19,11 @@ Pod::Spec.new do |s|
s.pod_target_xcconfig = { "OTHER_LDFLAGS" => "-undefined dynamic_lookup" }
s.dependency 'SwiftBytes', '~> 0.2'
s.dependency 'CocoaAsyncSocket', '~> 7.4'
s.dependency 'CocoaAsyncSocket', '~> 7.4.0'
s.dependency 'lz4', '~> 128'
s.dependency 'Base32', '~> 1.0.2'
s.dependency 'IGDigest', '~> 1.1.0'
s.dependency 'NetUtils', '~> 1.0'
s.dependency 'NetUtils', '~> 2.0'
s.dependency 'SelfSignedCert', '~> 1.0'
end
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment